Get in touch
Back
Maintenance

Server is down due to it not being needed for now.

Completed 25 Aug at 12:00am CEST.

CAS blog AI U!
Completed

Maintenance completed

Posted 25 Aug at 12:00am CEST.
Started

Will turn back on before I leave for university.

Posted 1 Aug at 12:00am CEST.